CMake Error at CMakeLists.txt:1 >> Upgrading cmake

(Last Updated On: May 16, 2020)
CMake Error at CMakeLists.txt:1 (cmake_minimum_required):
CMake 3.7 or higher is required. You are running version 2.8.12.2

딱 봐도 cmake 버전이 낮아서 안 된다는 것 처럼 보인다.
cmake 를 업그레이드 해주는게 좋겠다.

1 take cmake source file

2 build cmake

sudo su

mkdir /opt/cmake
curl -sL https://github.com/Kitware/CMake/releases/download/v3.17.0/cmake-3.17.0.tar.gz | tar xvz -C /opt/cmake --strip 1
cd /opt/cmake
./bootstrap
make -j$(nproc)
make install

3 check cmake version

cmake --version

4 wth

[[email protected] cmake]# cmake --version
CMake Error: Could not find CMAKE_ROOT !!!
CMake has most likely not been installed correctly.
Modules directory not found in
/usr/local/bin
Segmentation fault

???????????? 뭐야

ln -s /usr/local/bin/cmake /usr/bin/cmake

 

[[email protected] cmake]# bash
[[email protected] /opt/cmake]# cmake --version
cmake version 3.17.0

CMake suite maintained and supported by Kitware (kitware.com/cmake).

잘 업그레이드 되었다 ^^

Could NOT find OpenSSL

openssl-devel OR https://blog.kerus.net/2063/